Jump to content
Waynolt

SWM modular modpack [E18]

Recommended Posts

3 minutes ago, Sirrobert said:

That was quick.

It has been ready since October :P

Share this post


Link to post
Share on other sites
Spoiler

Wow you already update it on ep.17 :o btw thank you for this! i really need it especially for the water gym.

 

Edited by BlairSupernova

Share this post


Link to post
Share on other sites
1 hour ago, Waynolt said:

It has been ready since October :P

If i may ask,do i copy and paste the mods i want in the data folder?

Share this post


Link to post
Share on other sites
5 minutes ago, Pozyher said:

If i may ask,do i copy and paste the mods i want in the data folder?

Yes: every file in the Mods folder is loaded by the modded Scripts.rxdata file.

Share this post


Link to post
Share on other sites
3 minutes ago, Waynolt said:

Yes: every file in the Mods folder is loaded by the modded Scripts.rxdata file.

alright thank you for answering me and for making this mod :) 

Share this post


Link to post
Share on other sites

For some reasson, this doesn't work for me...

I replaced the Scripts.rpgxp file and put the Mods folder in the Data Folder.

 

Back in E16 I had no problems using this mod.

Share this post


Link to post
Share on other sites
13 minutes ago, TheTGU said:

For some reasson, this doesn't work for me...

I replaced the Scripts.rpgxp file and put the Mods folder in the Data Folder.

 

Back in E16 I had no problems using this mod.

What do you mean? Do you get an error message or nothing at all?

If the latter: please check that the extension is ".rxdata" and that there are files inside the Data\Mods folder.

If both are ok, please make sure that you have the file "SetWeather" in the Data\Mods folder and check if you do have the "Control weather" option in the pokegear.
 

Share this post


Link to post
Share on other sites
Just now, TheTGU said:

Well, all three are okay, so... :/

Well, if you do have the  "Control weather" option it means that the mod is installed and loaded correctly... what is the problem you're experiencing?

Share this post


Link to post
Share on other sites

Oh, I may have expressed myself wrongly, I don't have the option.

 

I checked the scripts file and the .rb files.

The first few lines of the script's main part (and also the only lines marked with MODDED):

#####MODDED
begin
    ModsPath = Dir.pwd+"/Data/Mods/*.rb"
    Dir[ModsPath].each {|file| load file }
end
#####/MODDED

The code of the .rb files also seems to be fine. (Though I'm not a coding expert)

Share this post


Link to post
Share on other sites
1 minute ago, TheTGU said:

Though I'm not a coding expert

Me niether, actually :P

The problem might be that, for some reason, the game cannot find the folder or its files... please try to use this Scripts.rxdata file (it will give out a message immediately before the loading screen, stating whether or not it did find files in the Mods folder and how many. If it doesn't find any file, then it can't find the Mods folder or its contents)

https://www.sendspace.com/file/u68vfm

Also, are you using windows or another operating system?

Share this post


Link to post
Share on other sites

Windows 10.

And also, I somehow broke my game by playtesting it xD

Well, gotta reinstall it...

Edited by TheTGU

Share this post


Link to post
Share on other sites
2 minutes ago, TheTGU said:

Windows 10.

And also, I somehow broke my game by playtesting it xD

The problem is win10 then.
(No actual reason, I just don't like win10 :D )
(On a more serious note: did you try the file? Did it find the contents in the Mods folder?)
(P.S: What do you mean you broke the game? You're a brute! :P  )

Edited by Waynolt

Share this post


Link to post
Share on other sites

It gives me the error message.

 

Well, I just solved the issue.

I put the Reborn folder on my Desktop and ran it from there.

Maybe it has something to do with how the location of the Mods folder is described in the Scripts file?

I guess I can try messing around with that...

 

Edit: It could have something to do with my E17 folder "Pokemon Reborn" being inside my E16 folder "Pokemon Reborn"

Edited by TheTGU

Share this post


Link to post
Share on other sites
7 minutes ago, TheTGU said:

Maybe it has something to do with how the location of the Mods folder is described in the Scripts file?

Maybe... the modded scripts.rxdata looks for the path of the current process.
Now that you mention it, I think I read somewhere that win10 has problems with some program paths (iirc if the program is installed in Program Files, because in some localizations it has another name)

Please try this file, it will tell you what path is it looking for exactly (so that you can check if it is the correct install path):
https://www.sendspace.com/file/c14oqj

Edited by Waynolt

Share this post


Link to post
Share on other sites
7 minutes ago, TheTGU said:

Well, I just solved the issue.

I put the Reborn folder on my Desktop and ran it from there.

Maybe it has something to do with how the location of the Mods folder is described in the Scripts file?

I guess I can try messing around with that...

 

Edit: It could have something to do with my E17 folder "Pokemon Reborn" being inside my E16 folder "Pokemon Reborn"

Tbh, i recommend you to separate E17 from E16 to avoid errors.

Share this post


Link to post
Share on other sites

Well, it's looking for the right directory...

D:/Pokémon Reborn/Reborn17-0-2/Pokemon Reborn/Data/Mods/

 

On 12/3/2017 at 1:51 PM, Ainz Ooal Gown said:

Tbh, i recommend you to separate E17 from E16 to avoid errors.

Well, it's now on my Desktop and working just fine :)

Share this post


Link to post
Share on other sites
4 minutes ago, TheTGU said:

Well, it's now on my Desktop and working just fine :)

Maybe then it is indeed as you wrote, and it has problems with it being inside E16's folder... have you tried moving E17 to D:/Pokemon Reborn 17-0-2/ (so that the path is D:/Pokemon Reborn 17-0-2/Data/Mods/) or something similar?
Another option would be to just be happy that you got it working, even though we don't know for sure the reason :P

Edited by Waynolt

Share this post


Link to post
Share on other sites
Just now, TheTGU said:

It works.

Ok, then we can say that that was the problem. Have fun!

Share this post


Link to post
Share on other sites
7 minutes ago, Ainz Ooal Gown said:

One question : how to disable one of the mods?

Remove its file from the Mods folder.

  • Thanks 1

Share this post


Link to post
Share on other sites

Hello there. Unfortunately the mods aren't working for me. I copied the scripts and all the files on the mod folder to the PokemonReborn/Data yet its not working. Specifically the No TMx mod and the select weather app isn't showing on my pokegear.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...