Jump to content

V13 patched and V13.0.2 pre-patched game error on launch (Linux)


Recommended Posts

I have attempted to patch my V13 game with the 13.0.2 patch, and I get the error attached. This also happened when I attempted to download and run the pre-patched V13.0.2 game. The error seems self-explanatory. The item showing the program in which sequence to run the provided scripts doesn't exist.

 

Luckily I backed up my unpatched V13 so I can still continue playing on that.

Screenshot from 2021-07-21 11-47-23.png

Link to post
Share on other sites

Hey, I seem to have ran into the same thing (in an other thread); it looks like the linux archive has some missing files, or my decompressing tool wiped out the whole script directory. I copied the missing files (the Script dir) from the mac release. The Scripts directory should have 185 files (including script_order). Then I applied the patch as normal. What I find weird is that you seemed to have a functional V13 until patching, I hadn't it run until I did that.

 

That, or there were some shenanigans and we were not supposed to get all the scripts and the export/import script is hurting itself in its confusion.

 

I could even pass along a zip with all the files as it seems to be correct (but you shouldn't trust a fellow internet denizen, particularly with executables)

Link to post
Share on other sites
26 minutes ago, Nullspace said:

Hey, I seem to have ran into the same thing (in an other thread); it looks like the linux archive has some missing files, or my decompressing tool wiped out the whole script directory. I copied the missing files (the Script dir) from the mac release. The Scripts directory should have 185 files (including script_order). Then I applied the patch as normal. What I find weird is that you seemed to have a functional V13 until patching, I hadn't it run until I did that.

 

That, or there were some shenanigans and we were not supposed to get all the scripts and the export/import script is hurting itself in its confusion.

 

I could even pass along a zip with all the files as it seems to be correct (but you shouldn't trust a fellow internet denizen, particularly with executables)

Question for you, now that you have done this, do the patches work in that you receive money from early game battles?

Link to post
Share on other sites
24 minutes ago, jrichy2750 said:

Question for you, now that you have done this, do the patches work in that you receive money from early game battles?

I had been messing with the code and debug mode, thus things may vary; but yes it seems to work all right.

 

Also (to facilitate searching the error, screen-caps are not useful for this; I have seen several instances): Error linux: ENOENT script_order line 263 File Not Found

Link to post
Share on other sites
15 hours ago, Nullspace said:

Hey, I seem to have ran into the same thing (in an other thread); it looks like the linux archive has some missing files, or my decompressing tool wiped out the whole script directory. I copied the missing files (the Script dir) from the mac release. The Scripts directory should have 185 files (including script_order). Then I applied the patch as normal. What I find weird is that you seemed to have a functional V13 until patching, I hadn't it run until I did that.

 

That, or there were some shenanigans and we were not supposed to get all the scripts and the export/import script is hurting itself in its confusion.

 

I could even pass along a zip with all the files as it seems to be correct (but you shouldn't trust a fellow internet denizen, particularly with executables)

 

That worked bro. Thanks. It's not your decompression tool btw. The linux version is in-fact missing those files.

I extracted it on my linux machine, a mac machine, and using 7zip on a windows machine. All attempts to extract yielded the same result.

Link to post
Share on other sites

I was also having that problem but ended up using the original scripts file and the game worked; however, I’m not earning money from trainer battles even though I applied everything else in the patch. Anyone know a solution?

Link to post
Share on other sites
38 minutes ago, Flaffney64 said:

I was also having that problem but ended up using the original scripts file and the game worked; however, I’m not earning money from trainer battles even though I applied everything else in the patch. Anyone know a solution?

If you are on Mac, there is a direct pre patched download if you go to the download tab of rejuvenation on this website. Not sure if it is the same for Linux, but it would be worth a shot.

  • Like 1
Link to post
Share on other sites

I download the pre-patched game on my mac but when i tried to open it, i have the message : "pokemon rejuvenation is damaged and can't be opened."

How fix it?

 

 

Link to post
Share on other sites
×
×
  • Create New...