Jump to content
Sign in to follow this  
Draco456

Missing Move

Recommended Posts

Why is Spectral Thief not in this game, even in Debug? And when will you add it?

Share this post


Link to post
Share on other sites

When Pokemon Spork started development, the most recent gen was Gen 6. Any Gen 7 moves and abilities that were added later are ones I was able to script in myself (if they shared the same effect as already existing moves) or if I was able to find a script for them on Pokecommunity. Some of the scripts I tried for some moves and abilities caused errors when I tried to add them, and Spectral Thief was one of them. I don't have any scripting experience or knowledge, so whether I'll be able to add any currently missing moves and abilities in the future relies on if someone else would be able to do it for me.

Share this post


Link to post
Share on other sites

What were the others you couldn't add for that reason, just so I'm forewarned?

Share this post


Link to post
Share on other sites

I recall Shell Trap wasn’t programmed in Spork either.

 

But this Link is actually a pretty good source for programming attacks.

Share this post


Link to post
Share on other sites
8 hours ago, Draco456 said:

What were the others you couldn't add for that reason, just so I'm forewarned?

There's a notepad file in the game folder, gen7and8movesandabilities, that lists all of the ones I was able to add

 

Thank you for the link, though do you know which version of Essentials that script is for? The post is from 2019 and I think v17 was out then, while Spork uses v16.2

 

edit: got this error when testing the move

 

image.png.a28c551f8a15aa47f7c9f24e4d10edd2.png

 

Looking more at the thread, I think this might actually be the Spectral Thief script I tried before that gave errors. The poster is quoting a user named Rot8r_ConeX, who I remember was one of the people who were very active with posting scripts for Gen 7 moves and abilities for Essentials around the time Sun and Moon came out. The person quoting also asks about a way to update that script for v17.2. When Sun and Moon came out v16.2 was the most recent version of Essentials iirc, so it does seem likely this is the same script I tried before. Still, thank you for trying to help.

Share this post


Link to post
Share on other sites

The fact that you said that Pokemon Spork uses the 16.2 version of Pokemon Essentials actually helps me in my search, as I know I saw a script for Spectral Thief for that version. Give me a moment to find it.

 

Try this page, 10th post down, 2nd script box: https://www.pokecommunity.com/showthread.php?t=383035&page=3

 

The only thing I'm not sure of is whether or not that script takes into account the fact that Spectral Thief bypasses Substitute. Because that is indeed confirmed by Bulbapedia and Serebii.net

 

(Which, by the way, I think is one of the most salty things in Pokemon ever. Makes me chuckle just thinking about that.)

Share this post


Link to post
Share on other sites
2 hours ago, Draco456 said:

The fact that you said that Pokemon Spork uses the 16.2 version of Pokemon Essentials actually helps me in my search, as I know I saw a script for Spectral Thief for that version. Give me a moment to find it.

 

Try this page, 10th post down, 2nd script box: https://www.pokecommunity.com/showthread.php?t=383035&page=3

 

The only thing I'm not sure of is whether or not that script takes into account the fact that Spectral Thief bypasses Substitute. Because that is indeed confirmed by Bulbapedia and Serebii.net

 

(Which, by the way, I think is one of the most salty things in Pokemon ever. Makes me chuckle just thinking about that.)

This one worked, thanks! Spectral Thief has been added for the next reupload!

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...