Jump to content

V13 debug mode + auto speed up in battle (updated for 13.0.5)


EvGym
 Share

Recommended Posts

1 hour ago, EvGym said:

All the stuff has to do with variables. They are rather straight forwardly named so you can try that, just keep a backup. Until they release the PBS file I will be unable to help you further, sorry.

Yea Ive tried messing with them, im not sure what does what though. Ive basically messed with anything that had Saki in it but no luck so far in finding anything linked to the event. But its all good bro appreciate it

Link to comment
Share on other sites

4 hours ago, Milotic said:

Yea Ive tried messing with them, im not sure what does what though. Ive basically messed with anything that had Saki in it but no luck so far in finding anything linked to the event. But its all good bro appreciate it

Another idea comes to mind. Load a backup and re-go through the saki event. Tedious but  it might fix it. They should be located in your saves folder

Link to comment
Share on other sites

1 hour ago, generalguy64 said:

How do you install and use this mod? Just so I can get the right IVs for my team.

copy and paste the files into your scripts folder.

Link to comment
Share on other sites

On 8/4/2021 at 6:30 PM, EvGym said:

copy and paste the files into your scripts folder.

Bro another quick question, with the debug are we able to revert back to the legacy sprites? I had my old school sprite up until the geara fight, then it changed into the newly designed character sprite. Was wondering if I could mess with the switches or maybe replace the graphics folder potentially

Link to comment
Share on other sites

5 hours ago, Milotic said:

Bro another quick question, with the debug are we able to revert back to the legacy sprites? I had my old school sprite up until the geara fight, then it changed into the newly designed character sprite. Was wondering if I could mess with the switches or maybe replace the graphics folder potentially

It will probably involve  just replacing the sprites in your graphics folder

  • Like 1
Link to comment
Share on other sites

7 hours ago, Ibrex2000 said:

Can I get the debug mode and auto speed up together, or just one at a time? Also where do you place the speed up?

Everything goes into the scripts file and they both live on separate files. They are 100% compatible.
The only way a mod will be incompatible is if they replace the same scripts file.

 

All .rb files go into the scripts folder.

  • Like 1
Link to comment
Share on other sites

  • 5 weeks later...

PLEASE REDOWNLOAD THE SPEEDUP MOD
A bug, unrelated to my code strangely enough, caused newly caught wild pokemon to not appear in your box.

 

Sorry for the inconvenience,

Gym

Link to comment
Share on other sites

I'm honestly not sure if this is doable, but I thought I would ask anyway? Is there any possibility of making pgup and pgdn work again for jump scrolling? It used to work in older versions of the game, but now it doesn't (for me at least). When using debug mode to sift through long lists, it's quite tedious to get where I need to be.

Link to comment
Share on other sites

On 9/13/2021 at 1:26 PM, shibe said:

I'm honestly not sure if this is doable, but I thought I would ask anyway? Is there any possibility of making pgup and pgdn work again for jump scrolling? It used to work in older versions of the game, but now it doesn't (for me at least). When using debug mode to sift through long lists, it's quite tedious to get where I need to be.

Q is currently page up

W is currently page down
It should be possible to map these to pageup and down as well, but I am not all that interested in doing so.

Link to comment
Share on other sites

I m getting an error when i m resetting the game neat gearen lab in the bushes( to be specific )

D:/@raw/PKMN/Rejuvenation - v13/Data/Mods/PokemonSystem.rb:141:in `update'
Scene_Map:71:in `block in main'
Scene_Map:69:in `loop'
Scene_Map:69:in `main'
Main:78:in `mainFunctionDebug'
Main:55:in `mainFunction'
Main:88:in `block (2 levels) in <main>'
Main:87:in `loop'
Main:87:in `block in <main>'
000:Export/Import Scripts:336:in `eval'

I dont know how i get this error

I dont recall getting this error before but i started getting this error after i patched the pyrolusite mod for reju.

Thanks.

 

edit1: sorry i dont know if this is the right place to post this. please excuse me.

Link to comment
Share on other sites

 Share

×
×
  • Create New...