Jump to content
botukon

Flickering Textures Mac.

Recommended Posts

This is a minor bug. Sometimes i get some missing/flickering textures. I'm running the mac version of this game. I think it happens during the day. I don't see it during night (yet). Sorry is this is already reported elsewhere. I couldn't find the issue while searching.

Screen Shot 2020-05-19 at 6.24.04 PM.png

Share this post


Link to post
Share on other sites
1 minute ago, botukon said:

This is a minor bug. Sometimes i get some missing/flickering textures. I'm running the mac version of this game. I think it happens during the day. I don't see it during night (yet). Sorry is this is already reported elsewhere. I couldn't find the issue while searching.

 

What version of the game 18.3/18.2?

Share this post


Link to post
Share on other sites
20 minutes ago, botukon said:

Its 18.3

try redownloading maybe an error happened while doing so

Share this post


Link to post
Share on other sites

That didn't fix it. I still get texture problems. I should be more specific that it seems to effect mostly the ground. So far only when outside buildings.

Share this post


Link to post
Share on other sites
5 hours ago, botukon said:

That didn't fix it. I still get texture problems. I should be more specific that it seems to effect mostly the ground. So far only when outside buildings.

Is it happening on both versions of the game application?

Share this post


Link to post
Share on other sites

Both versions? Do you mean 18.2 or 18.3? I use a Mac. The only native mac version I have played is 18.3. In the past I had to use wineskin to play this game. That version was 17.1. I did not have this issue before downing the Mac version, but it ran slow.

Share this post


Link to post
Share on other sites
On 5/19/2020 at 4:35 PM, botukon said:

This is a minor bug. Sometimes i get some missing/flickering textures. I'm running the mac version of this game. I think it happens during the day. I don't see it during night (yet). Sorry is this is already reported elsewhere. I couldn't find the issue while searching.

Screen Shot 2020-05-19 at 6.24.04 PM.png

hi!

so, first, what the fuck. 

what mac do you have?

Share this post


Link to post
Share on other sites

Its a Mid 2012 Macbook Pro. I have an update as well. The texture glitch is occurring in the first gym.

Screen Shot 2020-05-21 at 6.38.53 PM.png

Share this post


Link to post
Share on other sites

..............huh.

your computer is definitely not so old that it can't run 18.3... but it is definitely acting like it is.

my guess for this is that you're missing some opengl drivers? but i'm not exactly the most knowledgeable about mac hardware, though.

maybe see if those can be updated somehow?

Share this post


Link to post
Share on other sites

From what I can find, Mac OS X doesn't allow updating of opengl. It is tied to the version of OS X I am running. I'd have to upgrade the OS itself to update the drivers. I'm not certain if the drivers are the issue since I am running the version required (Sierra). Then again I know even less about Mac hardware than you.

Share this post


Link to post
Share on other sites
18 minutes ago, botukon said:

Then again I know even less about Mac hardware than you.

i don't actually own a mac

 

but anyway.

if you open up the reborn app itself and get to this folder: Pokemon Reborn.app\Contents\Resources

there should be a file called MKXP.json

try replacing it with the one i've attached and see if it works

mkxp.json

Share this post


Link to post
Share on other sites

I tried it and the glitch happened as soon as I started moving. It's horrible in the gym. The attached image started happening before I replaced the file you sent.

Screen Shot 2020-05-21 at 7.34.17 PM.png

Share this post


Link to post
Share on other sites

then i'm not sure that there's a fix for this

Share this post


Link to post
Share on other sites

Am I the only one to report this so far? Hopefully it can be fixed in future updates. It's my understanding that the Mac native version of the game is recent.

Share this post


Link to post
Share on other sites
40 minutes ago, botukon said:

Am I the only one to report this so far? Hopefully it can be fixed in future updates. It's my understanding that the Mac native version of the game is recent.

i only finished it and put it out a few weeks ago. this is the first time i've heard of this bug.

Share this post


Link to post
Share on other sites
Posted (edited)

I use the Linux version, and it does it occasionally. Not as drastically though.

Edited by Flaffney64

Share this post


Link to post
Share on other sites

I'll try upgrading my OS to High Sierra and that should also update my opengl. In some areas it kind of looks like textures are getting mixed.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, I've got the same bug (macbook pro mid-2012, OXS 10.14.6 Mojave, basically, same model but different OS version). I originally posted my description of the problem here:

before I noticed I was dumb and that issue was already reported (for some reason, I only looked in the subforums when checking whether that was a known bug, as I said, I'm dumb)

I tried explicitly disabling (or enabling just in case, although I assume this does nothing) openGL4 (via the mkxp.json config) as suggested by andracass but it didn't seem to have any effect either.

 

[edit: here's an additional video of the bug in case it helps (I went to the apophyll grotto as it seems to always happen there, but you can also admire the glitched rain in obsidia ward).

]

[edit2: uh... for some reason the framerate is super low, I don't know why, the video capture usually plays fine (and it did play smoothly *before* I saved it, but now it's... bad? go figure)]

Edited by Olxinos

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...