Jump to content
WNxDelirium

Game crashing (exception) on battle start, after sending Pokemon out

Recommended Posts

Some extra info because this doesn't actually happen if I'm running Game.exe or Game-z.exe directly, but if I'm attempting to "playtest" the game via RPG Maker XP. 

This is how I've been playing the game for several years now, the last time was on 18.1.1 and that is/was working fine. I'm guessing something to do with the optimization changes in 18.3 is causing this to happen, possibly a setting in RPGXP that needs to be changed that I'm unaware of... but anyway. Hoping someone has some experience with this and can point me in the right direction! 🙂

So far I've:
Unzipped the 18.3 folder, and run Game.exe and Game-z.exe from there directly. This works fine.
Unzipped the 18.3 folder into a fresh Essentials v16 folder (which has worked for all previous releases I've tried). Again the direct .exes work fine, opening the .rxproj and playtesting causes the crash after starting a battle.
Unzipped the 18.3 folder into a fresh Essentials v17.2 folder, just to see if that made a difference to the above (it didn't).
PBS files are up to date (downloaded from the FAQ yesterday). 

Example below, the exception gets thrown shortly after my Pokemon appears in the battle (like, the instant the shiny animation would otherwise start). This happens regardless of the pokemon in battle, and regardless of save file.

---------------------------
Pokemon Reborn
---------------------------
Exception: NoMethodError
Message: undefined method `length' for nil:NilClass
PokeBattle_ActualScene:3672:in `pbCommonAnimation'
PokeBattle_ActualScene:2714:in `pbSendOut'
PokeBattle_Battle:2757:in `pbSendOut'
PokeBattle_Battle:4324:in `pbStartBattleCore'
PokeBattle_Battle:4161:in `pbStartBattle'
PokemonField:1058:in `pbWildBattle'
PokemonField:1057:in `pbSceneStandby'
PokemonField:1059:in `pbWildBattle'
PokemonField:1056:in `pbBattleAnimation'
PokemonField:1056:in `pbWildBattle'

Thanks in advance!

 

EDIT: Missed the different subsections for various game errors, I figure this thread belongs in one of those instead. Apologies!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...